Page 1 of 1

'Use' macros and the cast queue

PostPosted: Sun Mar 04, 2012 3:15 am
by KysenMurrin
I'm almost finished levelling my Mage, who is Tailoring/Engineering. I've just put some Synapse Springs on my gloves, and thrown together an exact copy of the macro I used to use for them on my old Mage - which I haven't played since about last July. This is the macro:

#showtooltip Fireball
/run sfx=GetCVar("Sound_EnableSFX");
/console Sound_EnableSFX 0
/use 10
/cast Fireball
/run SetCVar("Sound_EnableSFX",sfx);
/script UIErrorsFrame:Clear()

The old macros were identical apart from using Frostbolt or Arcane Blast, and I know they worked. Now, though, when I'm spamming the spell and the gloves come off cooldown, it fails to cast almost every time, saying that another action is in progress.

Is this something to do with the custom lag tolerance setting? Is the queuing of my next Fireball while the current one is casting preventing the gloves from activating?

Re: 'Use' macros and the cast queue

PostPosted: Tue Mar 06, 2012 7:39 am
by Dragondin
KysenMurrin wrote:Is this something to do with the custom lag tolerance setting? Is the queuing of my next Fireball while the current one is casting preventing the gloves from activating?


it seems so. i have the same macro with my fire mage and the gloves are only activated if i wait between two fireball or at the next fireball after an instant.

Re: 'Use' macros and the cast queue

PostPosted: Sun Mar 18, 2012 3:44 am
by Pyrena
I seem to remember the Synapse Springs not stacking with certain on-use trinkets.

Re: 'Use' macros and the cast queue

PostPosted: Sun Mar 18, 2012 3:51 am
by KysenMurrin
Yes, they lock out with trinkets, but that's not the issue I'm having. It looks like I do have to eiter pause between Fireballs or wait until I'm casting an instant.

Re: 'Use' macros and the cast queue

PostPosted: Sun Mar 18, 2012 4:21 am
by Invisusira
Can I assume all that script bejankle is to get rid of the "fizzle" sound that happens when your cooldown isn't ready?

Try this:
1) In your World of Warcraft directory, make a new folder called "Sound"
2) Inside that folder, make one called "Spells"
3) Inside THAT folder, make one called "Fizzle"
4) Finally, inside that folder, place these files:
www.meowx.com/FizzleHolyA.wav
www.meowx.com/FizzleFrostA.wav

They're just silent .wav files that will overwrite the default ones. HolyA is the default fizzle sound for most any non-specific spell, FrostA is in there for Icy Veins, I think. Try it with that, see if perhaps all the scripting is messing it up.

Re: 'Use' macros and the cast queue

PostPosted: Sun Mar 18, 2012 4:36 am
by KysenMurrin
Not just the sound; it also stops it spamming the "spell is not ready" message on screen every 2 seconds.